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AgendaAgenda
• 1 What Is Digital Music
• 1 Audio File Formats and Standards
• 1 Building Your Music Collection

• 2 Cleaning up and editing recorded music
• 2 Organizing Your Music Library

• 3 Burning Music CDs
• 3 Making Videos and Slide Shows

using your music and Movie Maker

• Useful Web Links for More Information
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What What IsIs Digital Music?Digital Music?

• Music is represented as a stream of numbers.
– Measurements of recorded electrical voltage level at an instant (A to D).
– Use 16 bits (2 bytes) per measurement (sample).
– For stereo, two streams – one for each channel.
– Standard audio CD sample rate is 44,100 per second.
– Can convert the stream of numbers back to voltages (D to A).

• Number stream may be saved in various ways
– On an audio CD.
– In a music file on a PC hard disk (.WAV, .MP3 or .AAC)
– Music files may be compressed in various ways or left uncompressed.

• Look at a MP3 file with GoldWave Music Editor
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Sound Card / Chip BasicsSound Card / Chip Basics

• Able to output analogue stereo sound from digital output stream
(D to A conversion; i.e. numbers become an electronic wave form).

• Able to convert analogue stereo input to a digital sound stream
(A to D conversion; i.e. an electronic wave form to numbers).

• Connects to CD / DVD drive so PC can “play” music CDs.

• Card has Line-in, Line / Speaker out, and Microphone jacks.

• http://www.howstuffworks.com/sound-card.htm

http://www.howstuffworks.com/sound-card.htm
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Audio File Formats (1)Audio File Formats (1)
• Microsoft WAVE  (.WAV)

– 44,100 samples/sec, stereo, 16-bit samples each channel.
– Uncompressed, consumes about 10.6 MBytes per minute of sound

(44,100 * 2 * 2 * 60).
– Audio CD Quality (same specs).

• Motion Picture Experts Group Level 3 (.MP3)
– Compressed, size varies based on sample rate.
– 128K bits/sec (CD quality), 64 Kbits/sec (FM quality).
– At 128Kbits/sec, uses about 1 MB per minute of sound (10 to 1).
– Little point in going higher than 192Kbits/sec for MP3.
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Audio File Formats (2)Audio File Formats (2)
• MP3Pro (.MP3) – Newer Standard (Never caught on)

– Double compressed, size varies based on sample rate.
– 64 Kbps (CD quality), 48 Kbps (FM quality).
– At 64Kbps, uses about .5 MB / minute of sound.

• Microsoft Windows Media Audio (.WMA)
– Compressed, size varies based on sample rate.
– Supports Digital Rights Management standards.
– MS claims files about half the size of .MP3 files.

(Our experiments didn’t confirm that).

• Other Formats:
– Apple (.AAC), Ogg-Vorbis (.ogg), Free-Lossless (.FLAC)

• More Information
– http://ekei.com/audio

http://ekei.com/audio
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Building Your Music LibraryBuilding Your Music Library
• Convert your music CD collection to music files.

– Use any of the popular “rippers”.
• Buy “used” CDs (save about 50%) to rip.
• Borrow music CDs to rip?

– Friends, public library.
• Buy digital music on-line.

– $.99 per song, $9.99 per “album” sometimes less)
– Most stores now sell “unlocked” MP3 files.

• Record Internet streaming audio
– Use a tool like Total Recorder

• Convert your old audio tapes and LPs to music files.
– Need a “line-in” recording tool (e.g. Spin It Again or GoldWave).
– After recording, need to separate and “clean-up” the recorded sound.
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CD RippersCD Rippers
• Ripping (Definition)

– Copying contents of an Audio CD to your hard disk.
– Digital audio data is converted to: .WAV, .MP3., .WMA or .AAC
– Often audio album, artist and track information looked up

in Internet CD Database (CDDB).
– Legal, fair personal use of copyrighted material you own.

• Many CD rippers available (shareware, freeware, jukeboxes).
– http://www.freerip.com
– Easy – Place CD in your CD drive and “rip away”.
– Ripped files can go in any folder – usually “My Music”.

http://www.freerip.com/
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Converting Audio Tapes and LPsConverting Audio Tapes and LPs
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LineLine--In Preliminary Steps (1)In Preliminary Steps (1)
• Hook up equipment as per preceding diagram.
• Make sure Line-in is coming from RCA jacks (316 

milli-volt), not speaker jacks.
• Power on all the stereo equipment.
• Use Windows Volume Control to set levels and 

mute the Mic input.
• Clean the LP, tape heads, stylus, …
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LineLine--in Preliminary Steps (2)in Preliminary Steps (2)

• “Play” the tape / LP to be recorded into the line-in jack.
– PC speakers will output the sound.
– Tests reception and volume levels.

• Rewind or re-queue the audio to be recorded.

• Launch Line-in recording software
– GoldWave, MusicMatch, Audacity, …

• Adjust program settings as needed to record from Line-In.
– (Set MP3 bit rate to 128 or 160 – no point in going higher)
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LineLine--In Recording (1)In Recording (1)

• Best Approach:
– Record entire LP or tape as two large single MP3 files (easiest).
– Side 1 is one large MP3; Side 2 is a second large MP3.

• Activate the recording window in GoldWave or Spin It Again.

• Set the artist name, album name and track title (e.g. “Side 1”).

• Start Recording in the software.

• Start playing the LP, tape or single song you want to record.
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LineLine--In Recording (2)In Recording (2)

• Allow the album or tape side to play to completion.

• Stop the LP or tape on the player.

• Stop the recording software.

• Save the recorded file if necessary.

• Set up and proceed as above to record the second side
using track title “Side 2”.

• Set up for recording the next LP, tape or single song.
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Digital Music EditorsDigital Music Editors

• GoldWave (Shareware)
– Does line-in recording
– Full-featured music editor

• Audacity (Open Source)
– Does line-in recording
– Full-featured music editor

• Roxio Creator Suite - Music Editor

• Nero Suite - Wave Editor
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PostPost--Processing a Full AlbumProcessing a Full Album
• Use GoldWave, Nero Wave Editor, Roxio, Audacity

• Clean up each “side x” file with noise and hiss filters, 
mute and crop off start / end noise.

• Optional - can break each side up into individual files:
– Open the “full album” MP3 file for Side 1 or Side 2.
– View the entire wave form.
– Zoom in as needed.
– Identify start / end of each song

(short interval of 0 level between).
– Highlight the song from start to end

(include some silence at each end).
– Save the highlighted segment as a separate MP3 file.
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Organizing Your Music LibraryOrganizing Your Music Library
• Physical Placement of music files.

– Folder and file hierarchy important.
– Best is Artist > Album > Song name.
– Default is your personal “My Music” or “Music” folder.
– If have two hard drives, consider placing on second.

• Set up Descriptive “tags” in music files
– Artist name, song name, album name, genre, date
– Tedious work.  But, once done, these are recognized by all players 

and jukebox programs.

• Adjust physical file names based on tags.
• Use a Jukebox program to index your files into a Library.
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Jukebox ProgramsJukebox Programs

• Most support a Music Library to organize your music.
• Most support ripping from Audio CDs.
• A few support stereo recording off the sound card “line” input.
• All can play CDs and music files back through your sound card.
• Can usually convert between some file formats.
• Can often burn new music CDs with your favorite tracks.
• Most now support on-line music radio streams.
• Most now support on-line music stores for downloads.
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Popular Juke Box ProgramsPopular Juke Box Programs

• Microsoft Windows Media Player 10, 11 or 12
• ITunes V10
• VideoLan VLC (audio and video)
• WinAmp 5
• Rhapsody Real Player (not recommended)
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Music CD Burning ProgramsMusic CD Burning Programs

• Most Jukebox Programs (see previous).

• Roxio - Easy CD Creator or Easy Media Creator
– Good, easy to use, handles all media types.

• Ahead Software – Nero (CD & DVD)
– Good, easy to use , handles all media types..

• Ashampoo Burning Studio
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CD Burning TipsCD Burning Tips
• Use good quality media.
• Use media rated to desired speed (e.g. 40X).
• Burners should have full access to the CPU and HD.
• Enable “Burn Proof” buffer mode if available.
• Shut down background programs, especially those that 

access the Internet. For example:
– MS Internet Explorer, MS Personal Web Server.
– E-mail client (Outlook, Outlook Express or AOL).
– Stock tickers, indexers, power managers.
– Screen savers.
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Demo Demo -- Burning Audio CDsBurning Audio CDs
• Can use iTunes, Media Player, WinAmp, Roxio or Nero.
• Demo – creating and burning an iTunes Play List

– File > New Play List.
– Drag and drop songs from the Library to the Play List (about 23).
– Keep track of total playing time (< 70 minutes)
– Drag songs in the play list into preferred order or turn on shuffle.
– Edit > Preferences > Advanced (check your settings).
– Click the “Burn Disc” item on the File menu.
– Set the CD burning parameters for “Audio CD”.
– iTunes will check the collection and then begin the burn.
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Demo Demo -- Burning MP3 CDsBurning MP3 CDs
• Can use iTunes, Media Player, WinAmp, Roxio or Nero.
• Demo – creating and burning an iTunes Play List

– File > New Play List.
– Drag and drop songs from the Library to the Play List (about 200).
– Keep track of total playing time (< 650 minutes)
– Drag songs in the play list into preferred order or turn on shuffle.
– Edit > Preferences > Advanced (check your settings).
– Click the “Burn Disc” item on the File menu.
– Set the CD burning parameters for “MP3 CD”.
– iTunes will check the collection and then begin the burn.
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Making Video Slide ShowsMaking Video Slide Shows

• Start Windows Movie Maker
• Choose “New Video”
• Select photos to be included in the slide show
• Drag and Drop them into the time line.
• Specify slide transitions, durations
• Choose background music (optional)
• Drag and Drop it into the time line.
• Preview your video slideshow
• Publish (burn) your slide show video to:

– DVD
– Video CD
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Useful Web LinksUseful Web Links
• http://www.howstuffworks.com/cd.htm
• http://audacity.sourceforge.net/
• http://www.download.com/
• http://www.roxio.com
• http://www.nero.com/eng/index.html
• http://www.itunes.com
• http://www.videolan.org
• http://www.winamp.com
• http://www.microsoft.com
• http://www.ashampoo.com
• http://www.rhapsody.com

• http://www.audio4fun.com/

http://www.howstuffworks.com/cd.htm
http://audacity.sourceforge.net/
http://www.download.com/
http://www.roxio.com/
http://www.nero.com/eng/index.html
http://www.itunes.com/
http://www.videolan.org/
http://www.winamp.com/
http://www.microsoft.com/
http://www.ashampoo.com/
http://www.rhapsody.com/
http://www.audio4fun.com/
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Where To Find MusicWhere To Find Music

• http://www.napster.com/
• http://www.emusic.com/
• http://www.amazon.com
• http://www.walmart.com
• http://www.itunes.com
• http://www.midikaraoke.com/
• http://www.half.com/products/music/index.cfm
• http://www.secondspin.com

http://www.napster.com/
http://www.emusic.com/
http://www.amazon.com/
http://www.walmart.com/
http://www.itunes.com/
http://www.midikaraoke.com/
http://www.half.com/products/music/index.cfm
http://www.secondspin.com/
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